Status Page
Performance Degraded - Increased latency - Eastern States Issue Opened: Wednesday 1st of April 2020 8:39PM
  • Services affected:
Resolved
This issue is now marked as resolved.
Last Updated: 4 Years Ago
Resolved
The cause of the increased latency has been identified as a routing misconfiguration between 3rd parties. The issue has been addressed and traffic is now taking the expected path.
Last Updated: 4 Years Ago
Monitoring
We're aware of an issue resulting in increased latency to some game hosting networks located in the eastern states. We're looking into the cause and will provide further updates as we have them.
Last Updated: 4 Years Ago
Investigating